Building RethinkDB on a Raspberry Pi - Part 2 posted on 13 December 2013

I previously wrote about compiling RethinkDB on a Raspberry Pi.

I merged @davidthomas426’s branch in the branch next of RethinkDB (based on v1.11), and things seem to still work.
You can get this branch here: michel_arm.
Binary: http://justonepixel.com/rethinkdb/pi/20131213rethinkdb

Instructions to build are still the same, except that you do not need PyYaml anymore.
So far the only thing that doesn’t work (and that I am aware of) is the flag --bind all. You can track the progress on this bug on this GitHub issue.

I’ll be going home next week (and won’t travel with my raspberry pi), so I’ll try to spend some this week end to fix this --bind all flag issue.

List of packages installed with version:

[[email protected] ~]$ LIST=$(pacman -Sl); for ARG in $(pacman -Qq); do echo "$LIST" | grep " $ARG "; done
core acl 2.2.52-2 [installed]
extra apr 1.4.8-2 [installed]
extra apr-util 1.5.2-3 [installed]
core attr 2.4.47-1 [installed]
core autoconf 2.69-1 [installed]
core automake 1.14-1 [installed]
extra avahi 0.6.31-11 [installed]
core bash 4.2.045-5 [installed]
core binutils 2.23.1-3 [installed]
core bison 3.0.1-1 [installed]
extra boost 1.54.0-4 [installed]
extra boost-libs 1.54.0-4 [installed]
core bridge-utils 1.5-2 [installed]
core bzip2 1.0.6-5 [installed]
core ca-certificates 20130906-1 [installed]
extra ccache 3.1.9-1 [installed]
extra clang 3.3-1 [installed]
core cloog 0.18.0-2 [installed]
core coreutils 8.21-2 [installed]
core cracklib 2.9.0-2 [installed]
core cronie 1.4.9-5 [installed]
core cryptsetup 1.6.2-2 [installed]
core curl 7.33.0-3 [installed]
core db 5.3.28-1 [installed]
core dbus 1.6.18-1 [installed]
core device-mapper 2.02.104-1 [installed]
core dhcpcd 6.1.0-1.1 [installed]
core dialog 1:1.2_20130928-1 [installed]
core diffutils 3.3-1.1 [installed]
core dirmngr 1.1.1-1 [installed]
core dnssec-anchors 20130320-1 [installed]
core e2fsprogs 1.42.8-2 [installed]
core expat 2.1.0-3 [installed]
core fakeroot 1.20-1 [installed]
core file 5.15-1 [installed]
core filesystem 2013.05-2 [installed]
core findutils 4.4.2-5 [installed]
core flex 2.5.37-1 [installed]
core gawk 4.1.0-2 [installed]
extra gc 7.2.d-2 [installed]
core gcc 4.7.2-4 [installed]
core gcc-libs 4.7.2-4 [installed]
core gdbm 1.10-3 [installed]
core gettext 0.18.3.1-2 [installed]
extra git 1.8.4.2-1 [installed]
core glib2 2.38.2-1 [installed]
core glibc 2.17-5.1 [installed]
core gmp 5.1.3-2 [installed]
core gnupg 2.0.22-1 [installed]
extra gperftools 2.1-2 [installed]
core gpgme 1.4.3-1 [installed]
core gpm 1.20.7-4 [installed]
core grep 2.15-1 [installed]
core groff 1.22.2-5 [installed]
extra guile 2.0.9-1 [installed]
core gzip 1.6-1 [installed]
extra haveged 1.7.c-3 [installed]
extra htop 1.0.2-2 [installed]
core hwids 20130607-1 [installed]
core iana-etc 2.30-4 [installed]
extra icu 52.1-1 [installed]
extra ifplugd 0.28-14 [installed]
core inetutils 1.9.1.341-1 [installed]
core iproute2 3.11.0-1 [installed]
core iptables 1.4.20-1 [installed]
core iputils 20121221-3 [installed]
core isl 0.11.1-1 [installed]
core jfsutils 1.1.15-4 [installed]
core kbd 2.0.1-1 [installed]
core keyutils 1.5.8-1 [installed]
core kmod 15-1 [installed]
core krb5 1.11.4-1 [installed]
core ldns 1.6.16-1 [installed]
core less 458-1 [installed]
core libarchive 3.1.2-4 [installed]
core libassuan 2.1.1-1 [installed]
core libcap 2.22-5 [installed]
extra libdaemon 0.14-2 [installed]
core libedit 20130601_3.1-1 [installed]
core libffi 3.0.13-4 [installed]
core libgcrypt 1.5.3-1 [installed]
core libgpg-error 1.12-1 [installed]
core libgssglue 0.4-2 [installed]
extra libidn 1.28-2 [installed]
core libksba 1.3.0-1 [installed]
core libldap 2.4.37-1 [installed]
core libltdl 2.4.2-7 [installed]
core libmpc 1.0.1-2 [installed]
core libnl 3.2.22-1 [installed]
core libpipeline 1.2.4-1 [installed]
core libsasl 2.1.26-6 [installed]
core libssh2 1.4.3-2 [installed]
core libtirpc 0.2.3-2 [installed]
core libtool 2.4.2-7 [installed]
extra libunistring 0.9.3-6 [installed]
core libusbx 1.0.17-1 [installed]
core licenses 20130203-1 [installed]
core linux-api-headers 3.10.6-1 [installed]
core linux-firmware 20131013.7d0c7a8-1 [installed]
core linux-raspberrypi 3.10.19-3 [installed]
extra llvm 3.3-1 [installed]
extra llvm-libs 3.3-1 [installed]
core logrotate 3.8.7-1 [installed]
core lvm2 2.02.104-1 [installed]
core lzo2 2.06-3 [installed]
core m4 1.4.17-1 [installed]
core make 4.0-1 [installed]
core man-db 2.6.5-1 [installed]
core man-pages 3.54-1 [installed]
core mdadm 3.3-2 [installed]
core mpfr 3.1.2.p4-1 [installed]
core nano 2.2.6-2 [installed]
core ncurses 5.9-6 [installed]
core net-tools 1.60.20130531git-1 [installed]
core netctl 1.4-2 [installed]
community nodejs 0.10.22-1 [installed]
extra ntp 4.2.6.p5-17 [installed]
core openresolv 3.5.6-1 [installed]
core openssh 6.4p1-1 [installed]
core openssl 1.0.1.e-5 [installed]
aur package-query 1.2-2 [installed]
core pacman 4.1.2-4 [installed]
core pacman-mirrorlist 20130919-1 [installed]
core pam 1.1.8-2 [installed]
core pambase 20130928-1 [installed]
core patch 2.7.1-2 [installed]
core pciutils 3.2.0-4 [installed]
core pcre 8.33-2 [installed]
core perl 5.18.1-1 [installed]
extra perl-error 0.17021-1 [installed]
core pinentry 0.8.3-1 [installed]
core pkg-config 0.28-1 [installed]
core popt 1.16-7 [installed]
extra ppl 1.0-1 [installed]
core procps-ng 3.3.8-3 [installed]
community protobuf 2.5.0-3 [installed]
core psmisc 22.20-1 [installed]
core pth 2.0.7-4 [installed]
extra python2 2.7.6-1 [installed]
extra python2-pip 1.4.1-2 [installed]
extra python2-setuptools 1.3-1 [installed]
alarm raspberrypi-firmware-bootloader 20131124-1 [installed]
alarm raspberrypi-firmware-bootloader-x 20131124-1 [installed]
alarm raspberrypi-firmware-emergency-kernel 20131124-1 [installed]
alarm raspberrypi-firmware-tools 20131124-1 [installed]
core readline 6.2.004-2 [installed]
core reiserfsprogs 3.6.24-1 [installed]
community rng-tools 4-2 [installed]
core run-parts 4.4-1 [installed]
core s-nail 14.4.5-1 [installed]
extra screen 4.0.3-15 [installed]
core sed 4.2.2-3 [installed]
extra serf 1.3.2-1 [installed]
core shadow 4.1.5.1-7 [installed]
extra sqlite 3.8.1-2 [installed]
extra subversion 1.8.5-1 [installed]
core sudo 1.8.8-1 [installed]
core sysfsutils 2.1.0-8 [installed]
core systemd 208-2 [installed]
core systemd-sysvcompat 208-2 [installed]
core sysvinit-tools 2.88-12 [installed]
core tar 1.27.1-1 [installed]
core texinfo 5.2-2 [installed]
core tzdata 2013h-1 [installed]
extra unixodbc 2.3.2-1 [installed]
core usbutils 007-1 [installed]
core util-linux 2.24-1 [installed]
core vi 1:050325-3 [installed]
extra vim 7.4.86-1 [installed]
extra vim-runtime 7.4.86-1 [installed]
extra wget 1.14-3 [installed]
core which 2.20-6 [installed]
core wpa_actiond 1.4-2 [installed]
core wpa_supplicant 2.0-4 [installed]
core xfsprogs 3.1.11-2 [installed]
core xz 5.0.5-2 [installed]
extra yajl 2.0.4-2 [installed]
aur yaourt 1.3-1 [installed]
core zlib 1.2.8-3 [installed]